#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<!\S)(\w{1,3})(?:-\1)*-(\w+)(?!\S)"
Local $sString = "c-c-c-c-come oh-oh-oh-oh it's a bad life oh-oh-oh-oh" & @CRLF & _
"oh-oh-oh-oh" & @CRLF & _
"oh-oh" & @CRLF & _
"" & @CRLF & _
"a-b-c" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"c-c-c-c-come to home today c-c-c-c-come to me test-test-test-a"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)