$re = '/(?<!\S)(\w{1,3})(?:-\1)*-(\w+)(?!\S)/m';
$str = 'c-c-c-c-come oh-oh-oh-oh it\'s a bad life oh-oh-oh-oh
oh-oh-oh-oh
oh-oh
a-b-c
c-c-c-c-come to home today c-c-c-c-come to me test-test-test-a';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;