import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\S)(\\w{1,3})(?:-\\1)*-(\\w+)(?!\\S)";
final String string = "c-c-c-c-come oh-oh-oh-oh it's a bad life oh-oh-oh-oh\n"
+ "oh-oh-oh-oh\n"
+ "oh-oh\n\n"
+ "a-b-c\n\n\n"
+ "c-c-c-c-come to home today c-c-c-c-come to me test-test-test-a";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}