import Foundation
let pattern = #"(?<!\S)(\w{1,3})(?:-\1)*-(\w+)(?!\S)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
c-c-c-c-come oh-oh-oh-oh it's a bad life oh-oh-oh-oh
oh-oh-oh-oh
oh-oh
a-b-c
c-c-c-c-come to home today c-c-c-c-come to me test-test-test-a
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)