#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)a+b+c+"
Local $sString = "//Full String Matches" & @CRLF & _
"abc (this is the smallest string that will match.)" & @CRLF & _
"aabc" & @CRLF & _
"aabbbbbbccccc" & @CRLF & _
"" & @CRLF & _
"//Nopes" & @CRLF & _
"bbbbbcccc (needs at least 1 ‘a’)" & @CRLF & _
"bac (the a has to come first.)" & @CRLF & _
"cab" & @CRLF & _
"ac" & @CRLF & _
"abdc" & @CRLF & _
"" & @CRLF & _
"//Partial Matches" & @CRLF & _
"cabc" & @CRLF & _
"bbbbbabcccccc" & @CRLF & _
"caaaaaaaaaaaaaaaaaaaabccccccccccccccc" & @CRLF & _
"dddddddddddddaaaaaaabbbbbbbbbccccccccccceeeeeeeeeeeeeeee"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")