// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)a+b+c+").unwrap();
let string = "//Full String Matches
abc (this is the smallest string that will match.)
aabc
aabbbbbbccccc
//Nopes
bbbbbcccc (needs at least 1 ‘a’)
bac (the a has to come first.)
cab
ac
abdc
//Partial Matches
cabc
bbbbbabcccccc
caaaaaaaaaaaaaaaaaaaabccccccccccccccc
dddddddddddddaaaaaaabbbbbbbbbccccccccccceeeeeeeeeeeeeeee";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}