import Foundation
let pattern = #"a+b+c+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
//Full String Matches
abc (this is the smallest string that will match.)
aabc
aabbbbbbccccc
//Nopes
bbbbbcccc (needs at least 1 ‘a’)
bac (the a has to come first.)
cab
ac
abdc
//Partial Matches
cabc
bbbbbabcccccc
caaaaaaaaaaaaaaaaaaaabccccccccccccccc
dddddddddddddaaaaaaabbbbbbbbbccccccccccceeeeeeeeeeeeeeee
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)