using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"a+b+c+";
string input = @"//Full String Matches
abc (this is the smallest string that will match.)
aabc
aabbbbbbccccc
//Nopes
bbbbbcccc (needs at least 1 ‘a’)
bac (the a has to come first.)
cab
ac
abdc
//Partial Matches
cabc
bbbbbabcccccc
caaaaaaaaaaaaaaaaaaaabccccccccccccccc
dddddddddddddaaaaaaabbbbbbbbbccccccccccceeeeeeeeeeeeeeee";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}