re = /a+b+c+/m
str = '//Full String Matches
abc (this is the smallest string that will match.)
aabc
aabbbbbbccccc
//Nopes
bbbbbcccc (needs at least 1 ‘a’)
bac (the a has to come first.)
cab
ac
abdc
//Partial Matches
cabc
bbbbbabcccccc
caaaaaaaaaaaaaaaaaaaabccccccccccccccc
dddddddddddddaaaaaaabbbbbbbbbccccccccccceeeeeeeeeeeeeeee'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end