import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "a+b+c+";
final String string = "//Full String Matches\n"
+ "abc (this is the smallest string that will match.)\n"
+ "aabc\n"
+ "aabbbbbbccccc\n\n"
+ "//Nopes\n"
+ "bbbbbcccc (needs at least 1 ‘a’)\n"
+ "bac (the a has to come first.)\n"
+ "cab\n"
+ "ac\n"
+ "abdc\n\n"
+ "//Partial Matches\n"
+ "cabc\n"
+ "bbbbbabcccccc\n"
+ "caaaaaaaaaaaaaaaaaaaabccccccccccccccc\n"
+ "dddddddddddddaaaaaaabbbbbbbbbccccccccccceeeeeeeeeeeeeeee";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}