import re
regex = re.compile(r"a+b+c+", flags=re.MULTILINE)
test_str = ("//Full String Matches\n"
"abc (this is the smallest string that will match.)\n"
"aabc\n"
"aabbbbbbccccc\n\n"
"//Nopes\n"
"bbbbbcccc (needs at least 1 ‘a’)\n"
"bac (the a has to come first.)\n"
"cab\n"
"ac\n"
"abdc\n\n"
"//Partial Matches\n"
"cabc\n"
"bbbbbabcccccc\n"
"caaaaaaaaaaaaaaaaaaaabccccccccccccccc\n"
"dddddddddddddaaaaaaabbbbbbbbbccccccccccceeeeeeeeeeeeeeee")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")