using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*(\d{9}).*(\d{4}-\d\d-\d\d).*""(\d+:\d+:\d+)"".*""(.*)"".*""(.*)"".*""(\d*)"".*""(\d+:\d+:\d+)"".*""(\d+,\d+)""";
string input = @"""27311"" ""5.37876.00.00.100000"" ""502190787"" ""2016-01-28"" ""19:02:47"" ""Polska"" ""Przesyłanie danych"" ""Przesyłanie danych"" ""blackberry.net"" ""1020 kB"" ""0,00""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}