import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*(\\d{9}).*(\\d{4}-\\d\\d-\\d\\d).*\"(\\d+:\\d+:\\d+)\".*\"(.*)\".*\"(.*)\".*\"(\\d*)\".*\"(\\d+:\\d+:\\d+)\".*\"(\\d+,\\d+)\"";
final String string = "\"27311\" \"5.37876.00.00.100000\" \"502190787\" \"2016-01-28\" \"19:02:47\" \"Polska\" \"Przesyłanie danych\" \"Przesyłanie danych\" \"blackberry.net\" \"1020 kB\" \"0,00\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}