use strict;
my $str = '"27311" "5.37876.00.00.100000" "502190787" "2016-01-28" "19:02:47" "Polska" "Przesyłanie danych" "Przesyłanie danych" "blackberry.net" "1020 kB" "0,00"';
my $regex = qr/.*(\d{9}).*(\d{4}-\d\d-\d\d).*"(\d+:\d+:\d+)".*"(.*)".*"(.*)".*"(\d*)".*"(\d+:\d+:\d+)".*"(\d+,\d+)"/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}