// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#".*(\d{9}).*(\d{4}-\d\d-\d\d).*"(\d+:\d+:\d+)".*"(.*)".*"(.*)".*"(\d*)".*"(\d+:\d+:\d+)".*"(\d+,\d+)""#).unwrap();
let string = "\"27311\" \"5.37876.00.00.100000\" \"502190787\" \"2016-01-28\" \"19:02:47\" \"Polska\" \"Przesyłanie danych\" \"Przesyłanie danych\" \"blackberry.net\" \"1020 kB\" \"0,00\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}