# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".*(\d{9}).*(\d{4}-\d\d-\d\d).*\"(\d+:\d+:\d+)\".*\"(.*)\".*\"(.*)\".*\"(\d*)\".*\"(\d+:\d+:\d+)\".*\"(\d+,\d+)\""
test_str = "\"27311\" \"5.37876.00.00.100000\" \"502190787\" \"2016-01-28\" \"19:02:47\" \"Polska\" \"Przesyłanie danych\" \"Przesyłanie danych\" \"blackberry.net\" \"1020 kB\" \"0,00\""
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.