# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([^;]|^)(\n)/$1;$2/gm;t' <<< "A;1;
B;2
C;3"