$re = '/([^;]|^)(\n)/m';
$str = 'A;1;
B;2
C;3';
$subst = "$1;$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;