import re
regex = re.compile(r"([^;]|^)(\n)", flags=re.MULTILINE)
test_str = ("A;1;\n"
"B;2\n"
"C;3")
subst = "$1;$2"
result = regex.sub(subst, test_str)
if result:
print(result)