#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)score.*(?<!\d)\d\d?(?!\d)"
Local $sString = "Games >= 2 AND score between 10 and 60 and country = 2" & @CRLF & _
"Games >= 2 AND score between 10 and 60 and country = 23" & @CRLF & _
"Games >= 2 AND score between 10 and 60 and country = 234" & @CRLF & _
"Games >= 2 AND score between 10 and 60 and country"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")