import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "score.*(?<!\\d)\\d\\d?(?!\\d)";
final String string = "Games >= 2 AND score between 10 and 60 and country = 2\n"
+ "Games >= 2 AND score between 10 and 60 and country = 23\n"
+ "Games >= 2 AND score between 10 and 60 and country = 234\n"
+ "Games >= 2 AND score between 10 and 60 and country";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}