using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"score.*(?<!\d)\d\d?(?!\d)";
string input = @"Games >= 2 AND score between 10 and 60 and country = 2
Games >= 2 AND score between 10 and 60 and country = 23
Games >= 2 AND score between 10 and 60 and country = 234
Games >= 2 AND score between 10 and 60 and country";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}