re = /score.*(?<!\d)\d\d?(?!\d)/m
str = 'Games >= 2 AND score between 10 and 60 and country = 2
Games >= 2 AND score between 10 and 60 and country = 23
Games >= 2 AND score between 10 and 60 and country = 234
Games >= 2 AND score between 10 and 60 and country'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end