const regex = /score.*(?<!\d)\d\d?(?!\d)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('score.*(?<!\\d)\\d\\d?(?!\\d)', 'gm')
const str = `Games >= 2 AND score between 10 and 60 and country = 2
Games >= 2 AND score between 10 and 60 and country = 23
Games >= 2 AND score between 10 and 60 and country = 234
Games >= 2 AND score between 10 and 60 and country`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}