$re = '/score.*(?<!\d)\d\d?(?!\d)/m';
$str = 'Games >= 2 AND score between 10 and 60 and country = 2
Games >= 2 AND score between 10 and 60 and country = 23
Games >= 2 AND score between 10 and 60 and country = 234
Games >= 2 AND score between 10 and 60 and country';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);