import re
regex = re.compile(r"score.*(?<!\d)\d\d?(?!\d)", flags=re.MULTILINE)
test_str = ("Games >= 2 AND score between 10 and 60 and country = 2\n"
"Games >= 2 AND score between 10 and 60 and country = 23\n"
"Games >= 2 AND score between 10 and 60 and country = 234\n"
"Games >= 2 AND score between 10 and 60 and country")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")