# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^.*P\(([^|]+)\|([^=]+)=(\d+)(?:, +([^=]+)=(\d+))?\)$/method_to_use(model, {"$2": $3}, "$1")/gm;t' <<< "What is P(output2|cause3=2)
"