import Foundation
let pattern = #"^.*P\(([^|]+)\|([^=]+)=(\d+)(?:, +([^=]+)=(\d+))?\)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
What is P(output2|cause3=2)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"method_to_use(model, {"$2": $3}, "$1")"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)