const regex = /^.*P\(([^|]+)\|([^=]+)=(\d+)(?:, +([^=]+)=(\d+))?\)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*P\\(([^|]+)\\|([^=]+)=(\\d+)(?:, +([^=]+)=(\\d+))?\\)$', 'gm')
const str = `What is P(output2|cause3=2)
`;
const subst = `method_to_use(model, {"$2": $3}, "$1")`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);