package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*P\(([^|]+)\|([^=]+)=(\d+)(?:, +([^=]+)=(\d+))?\)$`)
var str = `What is P(output2|cause3=2)
`
var substitution = "method_to_use(model, {"$2": $3}, "$1")"
fmt.Println(re.ReplaceAllString(str, substitution))
}