re = /^.*P\(([^|]+)\|([^=]+)=(\d+)(?:, +([^=]+)=(\d+))?\)$/m
str = 'What is P(output2|cause3=2)
'
subst = 'method_to_use(model, {"$2": $3}, "$1")'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result