$re = '/^.*P\(([^|]+)\|([^=]+)=(\d+)(?:, +([^=]+)=(\d+))?\)$/m';
$str = 'What is P(output2|cause3=2)
';
$subst = "method_to_use(model, {\"$2\": $3}, \"$1\")";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;