// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^.*P\(([^|]+)\|([^=]+)=(\d+)(?:, +([^=]+)=(\d+))?\)$").unwrap();
let string = "What is P(output2|cause3=2)
";
let substitution = "method_to_use(model, {\"$2\": $3}, \"$1\")";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}