using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(All days)|(\s(Su|\s{3})(Mo|\s{3})(Tu|\s{3})(We|\s{3})(Th|\s{3})(Fr|\s{3})(Sa|\s{3}))$";
string input = @" Su Tu Th Sa";
RegexOptions options = RegexOptions.Multiline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}