const regex = /^(All days)|(\s(Su|\s{3})(Mo|\s{3})(Tu|\s{3})(We|\s{3})(Th|\s{3})(Fr|\s{3})(Sa|\s{3}))$/m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(All days)|(\\s(Su|\\s{3})(Mo|\\s{3})(Tu|\\s{3})(We|\\s{3})(Th|\\s{3})(Fr|\\s{3})(Sa|\\s{3}))$', 'm')
const str = ` Su Tu Th Sa`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}