re = /^(All days)|(\s(Su|\s{3})(Mo|\s{3})(Tu|\s{3})(We|\s{3})(Th|\s{3})(Fr|\s{3})(Sa|\s{3}))$/m
str = ' Su Tu Th Sa'
# Print the match result
str.match(re) do |match|
puts match.to_s
end