use strict;
my $str = ' Su Tu Th Sa';
my $regex = qr/^(All days)|(\s(Su|\s{3})(Mo|\s{3})(Tu|\s{3})(We|\s{3})(Th|\s{3})(Fr|\s{3})(Sa|\s{3}))$/mp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}