import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(All days)|(\\s(Su|\\s{3})(Mo|\\s{3})(Tu|\\s{3})(We|\\s{3})(Th|\\s{3})(Fr|\\s{3})(Sa|\\s{3}))$";
final String string = " Su Tu Th Sa";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}