// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(All days)|(\s(Su|\s{3})(Mo|\s{3})(Tu|\s{3})(We|\s{3})(Th|\s{3})(Fr|\s{3})(Sa|\s{3}))$").unwrap();
let string = " Su Tu Th Sa";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}