package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(All days)|(\s(Su|\s{3})(Mo|\s{3})(Tu|\s{3})(We|\s{3})(Th|\s{3})(Fr|\s{3})(Sa|\s{3}))$`)
var str = ` Su Tu Th Sa`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}