using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s+xmlns(:xsi)?\s*(:\w)?\s*=\s*\""(?<url>[^\""]*)\""";
string input = @" xmlns=""http://pilatmedia.com/xml/ibms/ondemand/v1-0""
xmlns:xsi=""http://pilatmedia.com/xml/ibms/ondemand/v1-0""
xmlns:content=""http://www.cablelabs.com/namespaces/metadata/xsd/content/1"" ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}