$re = '/\s+xmlns(:xsi)?\s*(:\w)?\s*=\s*\"(?<url>[^\"]*)\"/m';
$str = ' xmlns="http://pilatmedia.com/xml/ibms/ondemand/v1-0"
xmlns:xsi="http://pilatmedia.com/xml/ibms/ondemand/v1-0"
xmlns:content="http://www.cablelabs.com/namespaces/metadata/xsd/content/1" ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);