import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s+xmlns(:xsi)?\\s*(:\\w)?\\s*=\\s*\\\"(?<url>[^\\\"]*)\\\"";
final String string = " xmlns=\"http://pilatmedia.com/xml/ibms/ondemand/v1-0\"\n"
+ " xmlns:xsi=\"http://pilatmedia.com/xml/ibms/ondemand/v1-0\"\n"
+ "xmlns:content=\"http://www.cablelabs.com/namespaces/metadata/xsd/content/1\" ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}