re = /\s+xmlns(:xsi)?\s*(:\w)?\s*=\s*\"(?<url>[^\"]*)\"/m
str = ' xmlns="http://pilatmedia.com/xml/ibms/ondemand/v1-0"
xmlns:xsi="http://pilatmedia.com/xml/ibms/ondemand/v1-0"
xmlns:content="http://www.cablelabs.com/namespaces/metadata/xsd/content/1" '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end