const regex = /\s+xmlns(:xsi)?\s*(:\w)?\s*=\s*\"(?<url>[^\"]*)\"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s+xmlns(:xsi)?\\s*(:\\w)?\\s*=\\s*\\"(?<url>[^\\"]*)\\"', 'gm')
const str = ` xmlns="http://pilatmedia.com/xml/ibms/ondemand/v1-0"
xmlns:xsi="http://pilatmedia.com/xml/ibms/ondemand/v1-0"
xmlns:content="http://www.cablelabs.com/namespaces/metadata/xsd/content/1" `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}