import Foundation
let pattern = #"\s+xmlns(:xsi)?\s*(:\w)?\s*=\s*\"(?<url>[^\"]*)\""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
xmlns="http://pilatmedia.com/xml/ibms/ondemand/v1-0"
xmlns:xsi="http://pilatmedia.com/xml/ibms/ondemand/v1-0"
xmlns:content="http://www.cablelabs.com/namespaces/metadata/xsd/content/1"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)