// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)\s+xmlns(:xsi)?\s*(:\w)?\s*=\s*\"(?<url>[^\"]*)\""#).unwrap();
let string = " xmlns=\"http://pilatmedia.com/xml/ibms/ondemand/v1-0\"
xmlns:xsi=\"http://pilatmedia.com/xml/ibms/ondemand/v1-0\"
xmlns:content=\"http://www.cablelabs.com/namespaces/metadata/xsd/content/1\" ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}