#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d[\d_]+\d)"
Local $sString = "302_pp_kamenno_seriy_brown.jpeg" & @CRLF & _
"yasen_beliy_523_2.jpg" & @CRLF & _
"bej_yasen_beliy_601.jpeg" & @CRLF & _
"bej_yasen_beliy_601_601_601.jpeg" & @CRLF & _
"bej_yasen_beliy_6_687_6.jpeg"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")