import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d[\\d_]+\\d)";
final String string = "302_pp_kamenno_seriy_brown.jpeg\n"
+ "yasen_beliy_523_2.jpg\n"
+ "bej_yasen_beliy_601.jpeg\n"
+ "bej_yasen_beliy_601_601_601.jpeg\n"
+ "bej_yasen_beliy_6_687_6.jpeg";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}