use strict;
my $str = '302_pp_kamenno_seriy_brown.jpeg
yasen_beliy_523_2.jpg
bej_yasen_beliy_601.jpeg
bej_yasen_beliy_601_601_601.jpeg
bej_yasen_beliy_6_687_6.jpeg';
my $regex = qr/(\d[\d_]+\d)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}